Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
pandapurple
30.04.2021 09:59 •
Информатика
Сложить программу для нахождения всех двухцифровых чисел, которые делятся на N или содержат число N в
Показать ответ
Ответ:
fianketo05
19.04.2023 02:15
Function Square(x1, y1, x2, y2, x3, y3: real): real;
begin
Square := abs((x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1)) / 2;
end;
var
x1, y1, x2, y2, x3, y3, s1, s2: real;
begin
write('Задайте первый треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s1 := Square(x1, y1, x2, y2, x3, y3);
write('Задайте второй треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s2 := Square(x1, y1, x2, y2, x3, y3);
if s1 > s2 then writeln('Площадь первого треугольника больше')
else if s1 < s2 then writeln('Площадь второго треугольника больше')
else writeln('Площади треугольников равны');
end.
p.s. проверять существуют ли такие треугольники не нужно, т.к. они уже заданы и нам нужно определить площадь большего.
0,0
(0 оценок)
Ответ:
umka2345
05.09.2022 15:53
В C++
#include <iostream>
int main()
{
using namespace std;
const int n = 6;
double arr[n];
for (int i = 0; i < n; ++i)
{
cout << "Enter #" << i + 1 << " element: ";
cin >> arr[i];
}
for (int i = 0; i < n; ++i)
cout << arr[i] << " ";
cout << endl;
double p = 1.0;
bool flag = false;
for (int i = 0; i < n; ++i)
if (arr[i] < 0)
{
p = p * arr[i];
flag = true;
}
if (!flag)
p = 0.0;
cout << "Multiplication of negative: " << p << endl;
int imax = 0;
for (int i = 1; i < n; ++i)
if (arr[i] > arr[imax])
imax = i;
double s = 0;
for (int i = 0; i < imax; i++)
if (arr[i] > 0)
s += arr[i];
cout << "Sum of positive before max: " << s << endl;
double temp;
for (int i = 0, m = n - 1; i < n / 2; ++i, --m)
{
temp = arr[i];
arr[i] = arr[m];
arr[m] = temp;
}
for (int i = 0; i < n; ++i)
cout << arr[i] << " ";
cout << endl;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Quickfast77
04.07.2021 08:02
Скорость передачи данных через adsl-соединение равна 1 000 000 бит\с. через данное соединение файл размером 100мбайт. определите время передачи файла в минутах....
AliceRosen
04.07.2021 08:02
Скорость передачи данных через adsl-соединение равна 128 000 бит\с. определите наибольший размер файла, который может быть передан через данное соединение за 7 минут....
Raadzhab
28.08.2020 01:58
1.раздел д в диалоговом окне( 7 букв) . 2. перечень заранее изготовленных вариантов команд, выбирая которые, можно компьютером( 5 букв).3.устройство , позволяющее...
79272197114
17.06.2021 05:49
4) Дан фрагмент таблицы истинности для выражения F.Каким выражением может быть F?...
SchoolWolf
06.09.2020 22:00
Для передачи секретного сообщения используется код, состоящий из прописных букв алфавита от «к» до «ф» включительно. при этом все буквы кодируются одним и тем же...
ivan488
07.04.2021 19:11
Ккакой разновидности языков естественных или формальных может быть отнесена морская флажковая азбука...
yadlos38
10.02.2020 05:07
Научити как переводить в биты ,байты, кбайты и т.д...
рузик83
23.05.2020 19:50
Четверо пассажиров застряли в одном из зарубежных аэропортов в связи с нелетной погодой. Попробуйте по приведенным данным определить фамилию каждого из пассажиров,...
svyatoslavkorchagin
29.12.2021 04:37
Спешите предложения. вместо точек вставляйте -тся или -ться: 1.кто хочет ,тот хорошо 2.кто приобрести знания,тот трудностей,а их приодолеть. 3.не смерти нужно в...
2comS
29.12.2021 04:37
После двух последовательных снижений цены, первое из которых было на 20 %, а второе — на 10 %, стул стал стоить 108 грн. какой была первоначальная цена стула?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
Square := abs((x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1)) / 2;
end;
var
x1, y1, x2, y2, x3, y3, s1, s2: real;
begin
write('Задайте первый треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s1 := Square(x1, y1, x2, y2, x3, y3);
write('Задайте второй треугольник(x1,y1,x2,y2,x3,y3): ');
readln(x1, y1, x2, y2, x3, y3);
s2 := Square(x1, y1, x2, y2, x3, y3);
if s1 > s2 then writeln('Площадь первого треугольника больше')
else if s1 < s2 then writeln('Площадь второго треугольника больше')
else writeln('Площади треугольников равны');
end.
p.s. проверять существуют ли такие треугольники не нужно, т.к. они уже заданы и нам нужно определить площадь большего.
#include <iostream>
int main()
{
using namespace std;
const int n = 6;
double arr[n];
for (int i = 0; i < n; ++i)
{
cout << "Enter #" << i + 1 << " element: ";
cin >> arr[i];
}
for (int i = 0; i < n; ++i)
cout << arr[i] << " ";
cout << endl;
double p = 1.0;
bool flag = false;
for (int i = 0; i < n; ++i)
if (arr[i] < 0)
{
p = p * arr[i];
flag = true;
}
if (!flag)
p = 0.0;
cout << "Multiplication of negative: " << p << endl;
int imax = 0;
for (int i = 1; i < n; ++i)
if (arr[i] > arr[imax])
imax = i;
double s = 0;
for (int i = 0; i < imax; i++)
if (arr[i] > 0)
s += arr[i];
cout << "Sum of positive before max: " << s << endl;
double temp;
for (int i = 0, m = n - 1; i < n / 2; ++i, --m)
{
temp = arr[i];
arr[i] = arr[m];
arr[m] = temp;
}
for (int i = 0; i < n; ++i)
cout << arr[i] << " ";
cout << endl;
return 0;
}