В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Katrun15
Katrun15
06.08.2020 07:18 •  Информатика

Склавиатуры вводятся n чисел. составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. значение n и сами числа вводится с клавиатуры.

Показать ответ
Ответ:
vladaandreeva2
vladaandreeva2
01.10.2020 07:15

var

  n,o,p,k,i:integer;

  a:real;

begin

 repeat

   write ('N = ');readln(n);

 until (n>0);

 i:=0; 

 k:=0;

 p:=0;

 o:=0;

 repeat

   write ('Ввод: ');readln(a);

   i:=i+1;

   if a<0 then o:=o+1 else

    if a>0 then p:=p+1 else k:=k+1;

 until i=n;

 writeln ('Кол-во положительных: ',p);

 writeln ('Кол-во отрицательных: ',o);

 writeln ('Кол-во нулей: ',k);

 readln;

end.

0,0(0 оценок)
Ответ:
КапитанПрайс3000
КапитанПрайс3000
01.10.2020 07:15

program aa;
var minus, plus, zero, N, C, Q : integer;
begin
zero:=0;
plus:=0;
minus:=0;
C:=0;
writeln('Введите количество чисел);
read(N);
writeln('Вводите числа');
while C<N do begin
read(Q);
C:=C+1;
If Q=0 then zero:=zero+1;
If Q<0 then minus:=minus+1;
If Q>0 then plus:=plus+1;
end;
writeln('Нулей: ',zero);
writeln('Отрицательных: ',minus);
writeln('Положительных: ',plus);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота