В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gamar1
gamar1
25.02.2021 09:36 •  Информатика

Склавиатуры вводится натуральное число n. программа выводит максимальную нечетную цифру числа. написать программу на паскале.

Показать ответ
Ответ:
maksim5a
maksim5a
04.10.2020 00:07
Var
    max, n, t: integer;

begin
    readln(n);
    max := -1;
    while n > 0 do
    begin
        t := n mod 10;
        if (t mod 2 = 1) and (max < t) then
            max := t;
        n := n div 10;
    end;
    
    if max = -1 then writeln('Нет такого числа')
    else
        writeln('Max = ', max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота