Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
салонки
26.02.2023 16:43 •
Информатика
Склавиатуры вводится n чисел. написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. значение n также вводится с клавиатуры. язык с++
Показать ответ
Ответ:
Кашмамининагений
06.10.2020 11:31
#include<iostream>
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Psix007
03.11.2021 12:30
Кчему произвольное изменение расширения (с переименования)?...
Arsen00628
12.02.2022 21:45
Уравнение имеет вид a*x2+b*x+c = 0. решите уравнение, используя алгоритм, при а) a = 6, b = 1, c =-1, б)a=2, b=4, c=-5, в) a=4, b=0, c=-12 ( ! )...
МаксимНелучший
19.03.2020 17:51
Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8: первое число - номер вертикали (при счете слева направо), второе - номер горизонтали...
кирилл2127
11.08.2020 00:26
Составить алгоритмы решения с блок-схем, используя конструкцию циклического алгоритма. 1. найти произведение четных чисел в диапазоне от 10 до 40. 2. составить алгоритм сбора в лесу...
Cказочник
13.01.2023 16:13
Как записать это в виде формулы?для того чтобы число делилось на 3, достаточно, чтобы оно делилось на 9...
елелел1
27.07.2022 15:00
Опиши своими словами диск и флэш память и сравни их....
dzharullaev2015
27.07.2022 15:00
Информационный объём 4,5 кбайта содержит 3072 символа. какова мощность алфавита, при которого было записано это сообщение?...
ВіКтОрІя0901
17.12.2021 15:58
С! в ходе телевизионного шоу проводится смс-голосование: каждый телезритель отдат свой голос за одного из 12 артистов-участников шоу,отправляя сообщение с его номером. голос каждого...
Nurbakyt2103
23.03.2020 06:42
Написать программу по информатике.напишите программу которая выдает произведения только четных целых чисел....
Dashasha555
18.05.2023 03:43
Какое из перечисленных ниже устройств для работы лишнее принтер, сканер, плоттер, графический дисплей...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main()
{
int n, A, P = 0, O = 0, N = 0;
cout << "n = ", cin >> n;
for (int i = 0; i < n; i++)
{
cin >> A;
if (A > 0) P++;
else if (A < 0) O++;
else N++;
}
cout << "( < 0): " << O;
cout << "\n( = 0): " << N;
cout << "\n( > 0): " << P;
return 0;
}