В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Misani
Misani
13.04.2020 10:24 •  Информатика

Синформатикой
: составить программу - беседу с пользователем на любую тему
я вот сделала её ,но не знаю правильно или нет ,скажите кто это понимает правильно я сделала

Показать ответ
Ответ:
Исма124
Исма124
03.03.2022 01:02
Var
  s,sd:string;
  i,n,sum,d,err:integer;
begin
  Writeln('Введите строку для суммирования');
  Read(s);
  sum:=0;
  n:=Length(s);
  if n>0 then begin
    i:=2; sd:=s[1];
    while i<=n do begin
      if s[i]<>'+' then sd:=sd+s[i]
      else begin
        Val(sd,d,err);
        sum:=sum+d;
        sd:=''
      end;
      Inc(i);   
    end;
    Val(sd,d,err);
    sum:=sum+d
  end;
  Writeln('Сумма равна ',sum)
end.

Тестовые примеры:
Введите строку для суммирования
1+25+3
Сумма равна 29

Введите строку для суммирования
143+38+253+62
Сумма равна 496
0,0(0 оценок)
Ответ:
irazatula05
irazatula05
19.10.2021 20:52
Средняя глубина Черного моря — 1271 м, наибольшая- 2245 метров (вблизи Синопа). Протяженность моря между западной и восточной точками —около 1167 км, между северной и южной-624 километра. Наименьшая протяженность акватории в меридиональном направлении, между Крымом и берегом Анатолии (азиатской части Турции), 263 км. Длина береговой линии Черного моря — 4090 км, коэффициент изрезанности — около 1,8.На площади, занятой Черным морем, можно разместить две Великобритании. Азовское море соединяется с Чёрным морем Керченским проливом. Площадь его — около 38000 кв. км. Преобладающие глубины — 9-13 м, наибольшая — 14,5 м. Берега изрезаны слабо. Крупнейший залив - Таганрогский; у западного берега - система мелких заливов Сиваш. Южный берег моря холмистый, для северного и северо-восточного берегов характерны косы. В Азовское море впадают реки Дон, Кубань и другие, образуя лиманы. Климат континентальный, средняя температура воздуха летом +23?-24?, зимой -7 ?С. С конца декабря до конца февраля покрывается льдом. Течения неустойчивы. Вода отличается мутностью, море богато рыбой: судак, лещ, кефаль, осётр, и т. д. Главные порты: Ростов-на-Дону, Таганрог, Азов.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота