В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
artik12042003
artik12042003
05.05.2022 03:44 •  Информатика

Синформатикой напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.

Показать ответ
Ответ:
antonzagarinp00ule
antonzagarinp00ule
31.08.2020 12:51
C++:
for(int i = 0; i< 20; i++){
a[i]=rand()%101+100;
}
int pos=0;
for(int i = 0; i< 20; i++){
if(a[i]+a[i+1]<a[pos]+a[pos+1]){
pos=i;
}
0,0(0 оценок)
Ответ:
spinny9tim
spinny9tim
31.08.2020 12:51
Var a:array[1..20] of integer;
i,min,ind:integer;
begin 
randomize;
for i:=1 to 20 do begin
a[i]:=random(100)+100;
write(a[i]:4);
end;
writeln;
min:=a[1]+a[2];
for i:=2 to 19 do
if a[i]+a[i+1]<min then 
begin 
min:=a[i]+a[i+1];
ind:=i;
end;
write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота