В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Yarik176
Yarik176
26.07.2021 19:08 •  Информатика

Синформатикой ,10 класс. : напишите программу вычисления суммы всех элементов массива.проверьте работу программы на заданном массиве a={7,25,4.5,0,17,61,-10,0,1,-4,22}

Показать ответ
Ответ:
plplem9999
plplem9999
27.05.2020 23:20

var a:array[1..10000] of real;

  i,n:integer;s:real;

begin

  readln(n);

  s:=0;

  for i:=1 to n do

  begin

     read(a[i]);

     s:=s+a[i];

  end;

  writeln;

  write('s=',s);

end.

Проверяем решение

вводим n=11

затем вводим элементы массива 7,25,4.5,0,17,61,-10,0,1,-4,22

получаем ответ s=123.5

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота