В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ekaaaterina
Ekaaaterina
29.03.2020 14:16 •  Информатика

Си++ составить программу, вычисляющую и выводящую все члены числового ряда 1, 1/2! ,1/3! , …,1/n! , значение которых превышает 10-5.

Показать ответ
Ответ:
pandapurple
pandapurple
01.10.2020 06:26

#include<iostream>

using namespace std;
long double fac(int N)
{
if(N < 0) // если пользователь ввел отрицательное число
return 0; // возвращаем ноль
if (N == 0) // если пользователь ввел ноль,
return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)
else // Во всех остальных случаях
return N * fac(N - 1); // делаем рекурсию.
}
int main()

{
int N;
cout << "enter N: " ;
cin >> N;
for(int i = 0; i < N; i++)
cout << "a[ " << i << " ] = " << 1/fac(i) << endl;
}

 

данная программа вычисляет  значения ряда, до N-го члена ряда

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота