В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ариэль1606
Ариэль1606
02.11.2021 01:26 •  Информатика

сделать задания на python
Напишите программу, которая запрашивала бы у пользователя:

4. Дана строка. Вывести все слова, начинающиеся на букву "а" и слова оканчивающиеся на букву "я".

5. 1. Найти максимальный элемент численного массива и поменять его местами с минимальным.

5.2. Программа заполняет одномерный массив из 10 целых чисел числами, считанными с клавиатуры. Определить среднее арифметическое всех чисел массива. Заменить элементы массива большие среднего арифметического на 1.

6. 1. Составить программу для нахождения чисел из интервала [М, N], имеющих наибольшее количество делителей.

6.2.Четыре точки заданы своими координатами X(x1, x2), Y(y1, y2), Z(z1, z2), P(p1, p2). Выяснить, какие из них находятся на максимальном расстоянии друг от друга и вывести на экран значение этого расстояния. Вычисление расстояния между двумя точками оформить в виде процедуры

7. 1. Задана квадратная матрица. Переставить строку с максимальным элементом на главной диагонали со строкой с заданным номером m.

Показать ответ
Ответ:
tatianani
tatianani
15.11.2021 16:49

Система счисления - метод записи чисел с определённого набора специальных символов (цифр) и сопоставления этим записям возможных значений.

Системы счисления бывают: позиционные (пример, десятичная и двоичная СС), непозиционные (пример, арабская или римская СС), смешанные (пример, счёт минут, часов).

Основанием системы счисления - набор символов (цифр), используемых в каждом из разрядов данного числа для его изображения в данной системе счисления

ИЛИ

Основание системы счисления - количество цифр и символов, использующихся для записи и демонстрации числа.

0,0(0 оценок)
Ответ:
cisjxhskxhha
cisjxhskxhha
21.03.2021 17:39
Var p, q: longint;
  n, i, j, c: integer;
begin 
  // 1
  write('n=');readln(n);
  for i := 1 to n do begin
    q := 1;
    for j := 1 to i do q := q * i;
    p := p + q;
  end;
  writeln ('Значение = ', p);
  
  // 2
  write('Число годовых оценок=');readln(n);
  p:=0;
  for i := 1 to n do begin
    write('оценка: '); readln(c);
    if c = 5 then p := p + 1
    else if c = 2 then p := - 1;
  end;
  writeln(p > 0);
  
  // 3
  n := 20; p := MaxInt;
  for i := 1 to n do begin
    write('Введите высоту здания ', i, ': ');
    readln(c);
    if c < p then p := c;
  end;
  writeln('Минимальная высота: ', p);
  
  //4
  n := 20; p := -1;
  for i := 1 to n do begin
    write('Введите высоту здания ', i, ': ');
    readln(c);
    if c > p then p := c;
  end;
  writeln('Максимальное значение высоты: ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота