В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Санчоs
Санчоs
16.08.2020 14:10 •  Информатика

сделать программу в c# В соответствии с заданным вариантом написать программу вычисления

выражения, используя оператор switch и тернарный оператор.


сделать программу в c# В соответствии с заданным вариантом написать программу вычислениявыражения, и

Показать ответ
Ответ:
dashasviridenko
dashasviridenko
14.07.2020 22:46

В Windows полное имя файла на локальном диске начинается с имени диска (тут всё начинается с E:), затем идут названия папок в порядке вложенности, затем имя файла - имя и расширение, отделенные точкой. Все части отделяются друг от друга обратной чертой \. Можно также думать, что есть полное имя папки, а полное имя файла - это полное имя папки + имя файла.

1) Файлы видеозапись.avi, график.xls, мелодия.mp3 и презентация.ppt находятся прямо в корневой папке диска - в структуре к ним идет линия непосредственно от имени диска. Их полные имена выглядят так:

E:\видеозапись.avi

E:\график.xls

E:\мелодия.mp3

E:\презентация.ppt

2) На диске есть папка ТЕКСТЫ, её полное имя E:\ТЕКСТЫ. В ней лежат файлы буквы.txt и Онегин.doc. Полные имена:

E:\ТЕКСТЫ\буквы.txt

E:\ТЕКСТЫ\Онегин.doc

3) Папка ИЗОБРАЖЕНИЯ лежит на диске E:, её адрес E:\ИЗОБРАЖЕНИЯ.

Непосредственно в ней лежит пайл аквариум.bmp, его полное имя

E:\ИЗОБРАЖЕНИЯ\аквариум.bmp

Также в этой папке есть подпапка ФОТО (E:\ИЗОБРАЖЕНИЯ\ФОТО). В ней два файла Бия.jpeg и Катунь.jpeg. Полные имена:

E:\ИЗОБРАЖЕНИЯ\ФОТО\Бия.jpeg

E:\ИЗОБРАЖЕНИЯ\ФОТО\Катунь.jpeg

0,0(0 оценок)
Ответ:
IcecreamXD
IcecreamXD
14.02.2023 17:57

x - четное = x дает остаток 0 при делении на 2

Операция взятия остатка при делении в Паскале - mod, корень - sqrt, степень - power (если вы не используете старый Паскаль), квадрат - sqr, натуральный логарифм - log.

Код (Pascal):

const

 a = 3e-3;

 b = 4.65;

var

 x: integer;

 Z: real;

begin

 read(x);

 if x mod 2 = 0 then

   Z := sqrt(a + sqr(sin(x * x)) * b)

 else

   Z := power(a, 1 / 3) + b * b * log(b);

 write(Z)

end.

Пример ввода 1:

6

Пример вывода 1:

2.1393591605284

Пример ввода 2:

3

Пример вывода 2:

33.3751364128159

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота