В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Temka333333
Temka333333
01.06.2020 02:21 •  Информатика

сделать программу на c# кому не сложно! В соответствии с заданным вариантом написать программу, используя
оператор цикла while() или do while()
Задание:
С клавиатуры вводится число N (int). Определить, может ли
оно быть двоичным (т. е. состоять только из 1 и 0) при цикла for.

Показать ответ
Ответ:
daviduk2509
daviduk2509
11.10.2021 09:20

using System;

namespace restless

{

   class Program

   {

       static void Main(string[] args)

       {

           int N;

           bool _isBin = true;

           N = Convert.ToInt32(Console.ReadLine());

           N = Math.Abs(N);

           while (N > 0)

           {

               if (N % 10 != 0 && N % 10 != 1)

               {

                   _isBin = false;

                   break;

               }

               N /= 10;

           }

           Console.WriteLine(_isBin);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота