В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kamakina
kamakina
01.10.2022 14:39 •  Информатика

Сделать= а) написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем. б)написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

Показать ответ
Ответ:
Алина051206
Алина051206
26.05.2020 06:38

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int number, counter = 0;
   float average = 0;

   cout << "Enter the number: ";
   cin >> number;

   //1)
   for(int i = 0; i <= number; i++)
   {
      average += i;
   }
   average /= (number + 1);

   //2)
   for(int i = 0; i <= number; i++)
   {
      if(i % 2 == 0) //Если чётное
      {
         counter++;
      }
   }

   cout << "Average = " << average << endl;
   cout << "The amount of even elements: " << counter << endl;

   return 0;
}


Сделать= а) написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пол
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота