с задания в Python.
3. Опишите на языке Python строковый тип переменной (буквенный)
4. Опишите на языке Python целочисленный тип переменных
5. Опишите на языке Python команду, позволяющую вводить данные с клавиатуры
6. Опишите на языке Python команду, позволяющую вывести информацию на экран монитора.
7. Опишите на языке Python вещественный тип переменных
8. Опишите на языке Python следующее условие: "если значение переменной s больше значения переменной d, то максимуму m присвоить значение переменной s". Примечание: Отступы обязательно показывать( для обозначения отступа можно использовать символ #), синтаксис языка тоже никто не отменял
9. Напишите программу, вычисляющую площадь и периметр прямоугольника со сторонами a и b. если площадь больше периметра, то программа должна вывести значение площади, а если периметр больше, то программа должна вывести значение периметра. Оформление программы: см задание 8
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;
writeln('Matrix A:'); //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
writeln;
for j:=1 to n do
begin;
a[i,j]:=random(10);
write(a[i,j]:4);
end;
end;
writeln;
writeln('Matrix C:'); //аналогично
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
c[i,j]:=random(10);
write(c[i,j]:4);
end;
end;
for i:=1 to n do //сохраняем матрицу C для транспонации
for j:=1 to n do
ma[i,j]:=c[i,j];
writeln;
writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
c[i,j]:=ma[j,i];
write(c[i,j]:4);
end;
end;
writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
write(ma[i,j]:4);
end;
end;
end.
1. Які графічні зображення можна вставити у текстовий документ?
1. Рисунок — правильно
2. Графіка — неправильно
3. Фігури — правильно
4. Smart Art — правильно
5. Word Art — правильно
6. Діаграма — правильно
7. Таблиці — неправильно
2. З яких графічних примітивів може складатися графічне зображення у текстовому документі?
Прямої та кривої - ...
Прямої та ламаної - ...
Кривої та ламаної - ...
Лінії та фігури - правильно
3. Які властивості має лінія?
1. Форма, накреслення, тип, шаблон, колір -
2. Розмір, ширина, висота іб обтікання, межі, заливка -...
3. Форма, товщина, тип, шаблон, колір — правильно
4. Однорідна заливка, градієнтна заливка, заливка візерунком - ...
4. Як заливки фігури у текстовому документі?
1. Однорідна - так
2. Внутрішня - ...
3. Градієнтна — так
4. Заливка візерунком — так
5. Текстурна — так
6. Заливка рисунком — так
7. Заливка кольором — ...
5. Лінії яких видів можна побудувати у текстовому документі?
1. Пряма лінія, штрихова лінія, штрих-пунктирна лінія, розривна лінія - ...
2. Пряма лінія, сполучна лінія, крива, полілінія, мальована крива — так
3. Лінії, основні фігури, фігурні стрілки, елементи блок-схем, виноски, зірки, стрічки - ...
6. Для чого використовують клавішу Ctrl під час малювання графічних примітивів?
1. Малювання фігур при натиснутій клавіші Ctrl здійснюється від центра фігури, що малюється - так
2. Малювання фігур при натиснутій клавіші Ctrl здійснюється з верхнього лівого кута фігури, що малюється — ...
3. Якщо, малюючи овал або прямокутник, утримувати натиснутою клавішу Ctrl, то будуть створюватися фігури правильної форми - круг або квадрат -...
4. Утримання клаівші Ctrl під час побудови ліній та стрілок обмежує кути нахилу величинами, кратними 15° -
7. Для чого використовують клавішу Shift під час малювання графічних примітивів?
1. Малювання фігур при натиснутій клавіші Shift здійснюється від центра фігури, що малюється -...
2. Малювання фігур при натиснутій клавіші Shift здійснюється з верхнього лівого кута фігури, що малюється - ..
3. Якщо, малюючи овал або прямокутник, утримувати натиснутою клавішу Shift , то будуть створюватися фігури правильної форми - круг або квадрат - так.
4. Утримання клаівші Shift під час побудови ліній та стрілок обмежує кути нахилу величинами, кратними 15° — так
8. Яке призначення маркерів графічного об'єкта?
1. Для редагування створеного об'єкта - так
2. Для форматування створеного об'єкта — ...
9. Які є види маркерів графічного об'єкта?
1. Маркер змінення розмірів — так
2. Маркер редагування -..
3. Маркер змінення форми — так
4. Маркер форматування -...
5. Маркер обертання — так
10. Яке призначення даного елемента керування вкладки Формат? (рисунок в обьяснение)
1. Для заливки внутрішньої області об'єкта встановленим кольором — так
2. Для зафарбування контуру фігури встановленим кольором - ...
3. Для змінення виділеної фігури на іншу із збереженням форматування поточного об'єкта -...
11. Яке призначення даного елемента керування вкладки Формат? (рисунок в обьяснения)
1. Для заливки внутрішньої області об'єкта встановленим кольором -..
2. Для зафарбування контуру фігури встановленим кольором — так
3. Для змінення виділеної фігури на іншу із збереженням форматування поточного об'єкта -..
12. Яке призначення даного елемента керування вкладки Формат? (рисунок в обьяснение)
1. Для заливки внутрішньої області об'єкта встановленим кольором -..
2. Для зафарбування контуру фігури встановленим кольором -..
3. Для змінення виділеної фігури на іншу із збереженням форматування поточного об'єкта — так
Обьяснение:
рисунки в порядке ответов.
1 рис. - 10 вопрос
2 рис - 11 вопрос
3 рис - 12 вопрос