с заданием Язык C# (C sharp) 1)
написать программу, в которую пользователь вводит число. если число отрицательное( 0)-вычесть из числа 10. Если число равно нулю-вывести соответствующее сообщение.
2)
С# написать программу в которую пользователь вводит 2 числа программа должна вычесть из большего меньшее и вывести его на экран
3)
написать программу, в которую пользователь вводит свой рост вывести на экран выскоий если его рост больше или равен 180 и нормальный если рост меньше 180
program Primer; // Название программы
var // Раздел для описания переменных
a, b, max: integer; // Объявление целочисленных переменных:
a - хранение первого введенного с клавиатуры числа;b - хранение второго введенного с клавиатуры числа;max - хранение максимального из них.begin // Начало программы
writeln('Введите два целых числа:'); // Вывод сообщения в консоль формата:
Введите два целых числа:read(a, b); // Считываем с клавиатуры два числа
if a > b then // Если значение переменной a > b, тогда
begin // Начало цикла if
max := a; // В переменную max присваиваем значение переменной a
end // Конец цикла if
else // Иначе
begin // Начало цикла else
max := b; // В переменную max присваиваем значение переменной b
end; // Конец цикла else
writeln('Наибольшее число: ', max); // Вывод сообщения в консоль формата:
Наибольшее число: *значение переменной max*end. // Конец программы
Подумайте, как на самом деле работает сеть переменного тока. «AC» обозначает переменный ток , то есть он идет назад и вперед. Энергетические компании выдают вам электроэнергию на один полупериод, а затем откладывают все обратно на следующий полупериод. Какая ракетка!
Если серьезно, то «электричество» - это не вещь, скорее концепция. «Количество электричества» - это бессмысленная болтовня. Вы можете иметь определенное количество мощности, напряжения, тока или других измеримых свойств, но не «электричество». Для тех, кто не полностью понимает ток, напряжение и мощность, лучше всего вообще избегать использования слова «электричество», так как они, скорее всего, будут использовать его неправильно.
Поэтому, чтобы ответить на ваш вопрос, электричество никуда не уходит, потому что это не вещь или материал, который когда-либо был где-то на первом месте. Ток и напряжение вместе могут быть использованы для перемещения энергии. Когда батарея питает ваш планшет, он вырабатывает напряжение и ток, тем самым передавая энергию изнутри его наружу. Планшет использует эту мощность для работы компьютера внутри, освещения экрана, передачи данных по радиоволнам и т. Д.
Энергия (а сила, сила - это просто энергия за время) не создается и не разрушается, а просто перемещается. В случае, когда батарея питает планшет, энергия начинает заряжаться в химической форме внутри батареи. Затем он принимает электрическую форму, выходящую из батареи. Планшет использует его в электрической форме, но в конечном итоге он превращается в тепло. Если вы оставите планшет работать, просто сидя там, вы должны заметить, что он немного теплее, чем тот, на котором он сидит. Энергия, которая была в батарее в химической форме, теперь находится в веществе, из которого сделан планшет, в тепловой форме. В конечном итоге это приведет к нагреву воздуха в комнате, к нагреву чего-либо еще и т. Д. К тому времени, когда относительно небольшое количество энергии в батарее для планшета распределяется по всей комнате, вам понадобятся чувствительные научные инструменты для ее обнаружения.