В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
альбина350
альбина350
07.07.2022 10:14 •  Информатика

с задание (Assembler, компилятор MASM): Написать программу, что создает новый поток, который сортирует слова в ленте в порядке убывания длины слова. Отсортирована лента записывается в файл.

Показать ответ
Ответ:
sol9
sol9
22.12.2021 08:45

1. Три ряда и два столбца размечаем :

Столбцы: "Год", "Месяц"

Ряды: "День рождения", "Текущая дата", "Возраст"

2. "День рождения" заполняем вручную, указываем в столбце "Год" - год рождения, в столбце "Месяц" - соответственно месяц рождения.

3. По формулам заполняем текущую дату в ряде "Текущая дата", формула для столбца "Год":

— "=YEAR(TODAY())", функция TODAY() - возращает текущую дату в формате Exel, функция YEAR() - принемает дату формата Exel и возращает год в виде целого числа.

— "=MONTH(TODAY())", работает схоже с предыдущей функцией, но в отличии от нее, определяет из текущей даты - месяц.

4. Заполняем ряд "Возраст", тут указываем формулы для столбца "Год" и"Месяц" простые формулы, где вычетаем из текущей даты - дату рождения.

фото закреплено


Вас в решении задачи: Известны год и номер месяца рождения человека, а также год и номер месяца сего
0,0(0 оценок)
Ответ:
zaninartur
zaninartur
23.11.2022 12:09

Запишу сразу в виде готовой программы:

var

x, a, b, c, d: real;

begin

x := 0.33;

a := Log10(Exp(x + 2));

b := 2 * Pi / Tan(45 * Pi / 180);

c := 3.14 * ArcSin(x);

d := Sqr(Tan(Sqr(x))) + Exp(Cos(x));

Writeln(a);

Writeln(b);

Writeln(c);

Writeln(d);

end.

Здесь в примере b, котангенс 45 -видимо имеется ввиду градусов (и поэтому там умножено на Pi / 180, чтобы перевести в радианы- ведь в Паскале все тригонометрические функции используют радианы). Но, если это имеется ввиду 45 радиан, то этот множитель нужно убрать.

Там же, вместо котангенса используется единица делённая на тангенс (т.к. функции котангенса в Паскале вроде нет).

Ну, можно и выписать оттуда сами выражения отдельно, как просят в задаче (только работать вне программы это всё равно не будет):

a) Log10(Exp(x + 2))

b) 2 * Pi / Tan(45 * Pi / 180)

c) 3.14 * ArcSin(x)

d) Sqr(Tan(Sqr(x))) + Exp(Cos(x))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота