В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Артур3009
Артур3009
07.10.2021 02:53 •  Информатика

, с задачей на с++. Удаление элемента
Удалите из массива элемент в индексом k. Обратите внимание, считывание и вывод массива уже написаны за вас, необходимо написать только фрагмент программы — само удаление элемента.

Входные данные

В первой строке задано натуральное число n (n≤100) и индекс k (0≤k
Примечание

Для того чтобы удалить из массива A последний элемент необходимо использовать инструкцию pop_back():

A.pop_back();
Размер массива уменьшится на единицу. Данная инструкция выдаст ошибку выполнения, если вызвать её на пустом векторе.


, с задачей на с++. Удаление элемента Удалите из массива элемент в индексом k. Обратите внимание, сч

Показать ответ
Ответ:
АнгелКрови
АнгелКрови
23.01.2022 01:31

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n, k;

   cin >> n >> k;

   vector <int> A(n);

   for (int i = 0; i < A.size(); i++) {

       cin >> A[i];

   }

   A.erase(A.begin() + k);

   for (int i = 0; i < A.size(); ++i) {

       cout << A[i] << " ";

   }

   cout << endl;

   return 0;

}

Объяснение:

Сам не ожидал найти решение в одну строку, удачи! :)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота