С++ Вам дан фрагмент программы, в котором создается двумерный массив и выводится на экран. Дополните эту программу таким образом, чтобы элементы в каждой строке были равны индексу этой строки.
#include
using namespace std;
int main() {
int n, m;
int arr[100][100];
cin >> n >> m;
// ваш код
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cout << arr[i][j] << " ";
}
cout << endl;
}
return 0;
}
Формат входных данных
В единственной строке входных данных вводятся два натуральных числа N и M, не превосходящие 100.
Формат выходных данных
Выведите N строк по M столбцов — заполненный соответствующим образом двумерный массив.
Примечания
Сдавать требуется только указанный фрагмент программы.
входные данные
3 4
10 8
выходные данные
0 0 0 0
1 1 1 1
2 2 2 2
0 0 0 0 0 0 0 0
1 1 1 1 1 1 1 1
2 2 2 2 2 2 2 2
3 3 3 3 3 3 3 3
4 4 4 4 4 4 4 4
5 5 5 5 5 5 5 5
6 6 6 6 6 6 6 6
7 7 7 7 7 7 7 7
8 8 8 8 8 8 8 8
9 9 9 9 9 9 9 9
как-то так
Объяснение:
1. Минимально необходимый набор устройств для работы компьютера содержит…
b) системный блок, монитор, клавиатуру
2. Программное обеспечение (ПО) – это:
совокупность программ, позволяющих организовать решение задач на компьютере
3.Прикладное программное обеспечение:
программы для решения конкретных задач обработки информации
Системное программное обеспечение:
программы для организации совместной работы устройств компьютера как единой системы
Назначение антивирусных программ
обнаружение и уничтожение вирусов;
контроль возможных путей распространения компьютерных вирусов;
обнаружение компьютерных вирусов;
«излечение» зараженных файлов;
6. К устройствам вывода графической информации относится…
b) принтер
7. Сканер – это …
c) устройство, которое создает цифровую копию текстовой и графической информации
8. Манипулятор типа мышь – это …
d) устройство ввода управляющей информации
9. Бит – это...
b) минимальная единица информации, принимающая значение 0 или 1
10. Что такое Корзина?
a) это средство дополнительной безопасности при удалении файлов или папок
11. Что такое Диалоговое окно команды?
a) окно, в котором пользователь выбирает или задает параметры запрашиваемой команды
12. Какие из указанных стандартных программ Windows позволяют создавать графические изображения?
c) Word Pad
d) Paint
13. Папка – это …
a) контейнер для программ и файлов в графических интерфейсах пользователя
14. Какой может быть длина названия файлов?
a) от 1 до 255 символов, включая пробелы
15. Как называется папка, в которую временно попадают удалённые объекты?
c) корзина
16. Какая из нижеприведенных записей может быть именем файла?
c) lacd.doc
17. Какие программы используют для уменьшения объема файлов?
a) программы-архиваторы
18 . Какие программы из ниже перечисленных являются антивирусными?
a) Doctor WEB, AVP
19. Растровое изображение создается с использованием…
точек различного цвета (пикселей)
20.Применение векторной графики по сравнению с растровой:
не влияет на объем памяти, необходимой для хранения изображения, и на трудоемкость редактирования изображения;
21. Что такое презентация PowerPoint?
a) демонстрационный набор слайдов, подготовленных на компьютере
22. Совокупность слайдов, собранных в одном файле, образуют…
b) презентацию
/** libraries */
#include <iostream>
#include <cmath>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
/** libraries */
using namespace std;
/** defines */
#define ll long long
#define ld long double
#define yes cout << "YES" << "\n"
#define no cout << "NO" << "\n"
/** defines */
void swap(ll *a, ll *b){
ll temp = *a;
*a = *b;
*b = temp;
}
ll nod(ll a, ll b){
if (a < b) {
swap(a, b);
}
if (b) {
return nod(b, a % b);
} else {
return a;
}
}
ll nok(ll a, ll b){
return a/nod(a,b)*b;
}
signed main() {
ios_base::sync_with_stdio(false);
cin.tie(nullptr);
cout.tie(nullptr);
ll a,b;
cin >> a >> b;
cout << nok(a,b);
}