В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
OtvettePlz
OtvettePlz
09.03.2022 05:40 •  Информатика

с тестом (Python)1.Напишите программу, которая по заданным двум числам a и b, выводит на экран результат целочисленного деления и остаток, в заданном формате (смотри примеры) На вход программы подается два числа: a и b
Необходимо вывести две строки:
в первой строке - результат целочисленного деления a на b
во второй строке - остаток от деления a на b
Форма вывода смотри в примере входных и выходных значений
Пример входных и выходных данных
Входные данные
15 6
Выходные данные
15//6=2
15%6=3
2.Вычислите значение целочисленной переменной c при a = 26 и b = 6:
с = a % b + b
В качестве ответа укажите одно число.
3.Вычислите значение целочисленной переменной c при a = 26 и b = 6:
b = a // b + b
c = a % b + a
В качестве ответа укажите одно число.
4.Вычислите значение целочисленной переменной c при a = - 22 и b = 4:
b = a // b + b
c = a % b + a
В качестве ответа укажите одно число.
5.Кролик Клевер пошел в пекарню за пирожками. Один пирожок стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков.

Входные данные: Программа получает на вход три целых числа: a, b, n
Выходные данные: Программа должна вывести два числа: стоимость покупки в рублях и копейках (формат вывода смотри в примерах)
Примеры
№ Входные данные Выходные данные
1 10 15 2 20rub. 30kop.
2 2 50 4 10rub. 0kop.

Показать ответ
Ответ:
zhadanovayuliy
zhadanovayuliy
29.04.2023 08:58
Const
  n = 8;

var
  a: array[1..n]of integer;
  i, j, k, max: integer;

begin
  max := -MaxInt;
  for i := 1 to n do
  begin
    write('a[', i, ']= ');
    readln(a[i]);
    if a[i] > max then max := a[i];
  end;
  writeln(' максимальный элемент массива = ', max);
  //сортировка методом пузырька
  for i := 1 to n - 1 do
    for j := 1 to n - i do
      if a[j] < a[j + 1] then begin
        k := a[j];
        a[j] := a[j + 1];
        a[j + 1] := k
      end;
  //вывод массива
  for i := 1 to n do write(a[i]:4);
end.

Тестовое решение:
a[1]= 12
a[2]= 4
a[3]= 6
a[4]= 23
a[5]= 4
a[6]= 7
a[7]= 8
a[8]= 1
 максимальный элемент массива = 23
  23  12   8   7   6   4   4   1
0,0(0 оценок)
Ответ:
хорошист548
хорошист548
18.04.2020 19:04

const

  n = 3;

  m = 4;

var

  matrix: array[1..n, 1..m] of integer;

  max, max_i, max_j, i, j: integer;

  sum: integer;

 

begin

  writeln('введите массив ',n, '*', m, ' элементов: ');

  for i : = 1 to n do

    for j : = 1 to m do

      read(matrix[i,j]);

     

  max : = matrix[1,1];

 

  for i : = 1 to n do

    for j : = 1 to m do

      if (max < matrix[i,j]) then

      begin

        max : = matrix[i,j];

        max_i : = i;

        max_j : = j;

      end;

 

  sum : = 0;

 

  for i : = 1 to n do

    sum : = sum + matrix[i, max_j];

   

  for j : = 1 to m do

    sum : = sum + matrix[max_i, j];

   

  matrix[max_i, max_j] : = sum;

 

  writeln('получившийся массив: ');

  for i : = 1 to n do

  begin

    for j : = 1 to m do

      write(matrix[i,j], ' ');

   

    writeln();

  end;

end.

пример:

введите массив 3*4 элементов:

1 2 3 4

55 6 7 8

9 10 11 12

получившийся массив:

1 2 3 4

141 6 7 8

9 10 11 12

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота