В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vb8515401
vb8515401
18.11.2020 07:57 •  Информатика

С! составить программу в паскале 1. найти сумму нечетных чисел в промежутке от 20 до n

Показать ответ
Ответ:
Doshik131
Doshik131
08.10.2020 17:24
Берем первое нечетное в этом диапазоне (21) и прибавляем к нему все числа через одно (т.е. тоже все нечетные), пока не выйдем за пределы n.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln('S=',Range(21,ReadInteger('n='),2).Sum)
end.

Пример
n= 250
S=15525
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота