В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kristina5171
kristina5171
28.12.2022 04:22 •  Информатика

с решением Решение на языке Паскаль

На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран произведение цифр числа, которые делятся на 2 и на 4. Если в числе нет таких цифр, требуется на экран вывести «NO».

Показать ответ
Ответ:

var N,digit,maxDigit: longint;

begin

readln(N);

maxDigit := N mod 10;

while N > 0 do

begin

digit := N mod 10;

if digit mod 3 = 0 then

if digit > maxDigit then

maxDigit := digit;

N := N div 10;

end;

if maxDigit = 0 then

writeln('NO')

else

writeln(maxDigit)

end.

Объяснение:

вроде так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота