В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
grigorievatany
grigorievatany
04.09.2022 05:42 •  Информатика

С приложения LEGO MINDSTORMS EV3 Home Edition напишите программу движения робота между преградами, как показано на рисунке ниже.

Показать ответ
Ответ:
KRAUSE1
KRAUSE1
10.11.2022 17:05

var

i, a, b, n, n2, j: longint;

s: string;

flag: boolean;

begin

Write('Введите через пробел границы диапазона: ');

Readln(a, b);

if b < a then begin n := a; a := b; b := n end;

if a < 11 then a := 11;

for i := a to b do

begin

Str(i, s);

n := Length(s); n2 := n div 2; flag := true; j := 1;

repeat

flag := (s[j] = s[n - j + 1]);

j := j + 1

until (not flag) or (j > n2);

if flag then Write(i, ' ')

end;

end.

Тестовое решение:

Введите через пробел границы диапазона: 800 1500

808 818 828 838 848 858 868 878 888 898 909 919 929 939 949 959 969 979 989 999

Объяснение:

0,0(0 оценок)
Ответ:
ksuna2103
ksuna2103
14.09.2022 18:40

7

2

мотор

торт

Торт

Объяснение:

writeln(length(s)) - вывод количества символов в строке

writeln(pos('о',s)) - вывод первой позиции символа 'о' в строке s

delete(s,3,2) - удаление в строке s 2-х символов начиная с символа под номером 3

writeln(s) - вывод получившейся строки s

t:=copy(s, 3, 3) - копирование в строку t 3-х символов строки s начиная с 3 символа (тор)

insert ('т',t,4) - вставка символа 'т' в строку t на позицию 4

writeln (t) - вывод получившейся строки t

t[1]:=UpCase(t[1]) - замена первого символа строки t на заглавный

writeln (t) - вывод получившейся строки t

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота