В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
198219821333
198219821333
13.05.2022 02:27 •  Информатика

с паскалем!
Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 9.

Показать ответ
Ответ:
sashaberts
sashaberts
10.12.2021 12:19
Program Turashova_Anna;

Const  V: String = '01';  
Function DecToN(A: Longint; D: Byte) : String; 
Begin  If A > D - 1  
then DecToN := DecToN(A div D, D) + V[(A mod D) + 1] 
else DecToN := V [A + 1]; 
end;    

Function NToDec(A: String; D: Byte): Longint;   
Begin   
If Length(a) > 0    
then NToDec := Pos(A [Length(A)], V) - 1 + D * NToDec(Copy (A, 1, Length(A) - 1), D)   
else NToDec := 0;   
end;

Var F: String;     
Begin     
Write('Входной файл Input.txt: '); Readln(F); 
If NToDec(F,2)      
mod 7 = 0      
then Writeln('Выходной файл Output.txt: 0',DecToN(NToDec(F,2) div 7,2))      
else Writeln('Выходной файл Output.txt: 0');     
end.
0,0(0 оценок)
Ответ:
артемий59
артемий59
07.04.2022 01:48
Знак это родовое понятие. тоесть общее имя букв и цифр и других знаков которые служат для представления информации на носителе
пиктограмма — элемент графического интерфейса пользователя; небольшое растровое изображение на видеоэкране, служащее для идентификации некоторого объекта: файла, программы и т.п...
Символ – это условный знак, который раскрывает смысл понятия, идеи, явления или события.
Знаковая система — это система однообразно интерпретируемых и трактуемых сообщений/сигналов, которыми можно обмениваться в процессе общения
Кодирование информации — процесс преобразования сигнала из формы, удобной для непосредственного использования информации, в форму, удобную для передачи, хранения или автоматической переработки
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота