В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
areskinaelina
areskinaelina
21.11.2021 20:23 •  Информатика

С оператора множественного выбора case,напишите программу ,которая по вводимому числу определяет возрастную категорию. Если 1...6 лет дошкольник ,7 ...17 школьник ,1860 рабочий, 61...100 пенсионер.​

Показать ответ
Ответ:
Bячеслав
Bячеслав
22.08.2022 21:20

Паскаль

Откомпилирован: (Pascal ABC)


program z1;
uses crt;
var
   n: integer;
   i: integer;
begin
    write(' Введите n :  ');
    readln(n);
   
    for i := 1 to n do
    begin
         writeln(' Число:',i,' Степень:', i *i);
    end;
end.

 

Си

Откомпилирован: (DEV Cpp)

#include <stdio.h>
#include <stdlib.h>
#include <conio.h>
#include <math.h>

int main()
{
 int n = 0;
 
 printf("\n Vvedite n:  ");
 scanf("%d", &n);

 printf("\n Chislo | Stepen");
 for(int i = 1; i < n; i++)
 {
         printf("\n %5d  |%5d ", i, i * i);
 }

 getch( );

 return 0;
}

0,0(0 оценок)
Ответ:
mikilinaf7890
mikilinaf7890
04.10.2020 19:22

Язык СИ (Откомпилирован и проверен был в Dev-C++)

 

#include <stdio.h>
#include <stdlib.h>
#include <conio.h>

int main()
{
    int a, b, c;
    printf("\n Vvedite 3 chisla :  ");
    scanf("%d" "%d" "%d", &a, &b, &c);
   
    if (a > b && a > c) printf("\n a = %d", a);
    if (b > c && b > a) printf("\n b = %d", b);
    if (c > b && c > a) printf("\n c = %d", c);
    if (a == b && a > c) printf("\n a = %d b = %d", a, b);
    if (a == c && a > b) printf("\n a = %d c = %d", a, c);
    if (b == c && b > c) printf("\n b = %d c = %d", b, c);
    if (a == b && a == c) printf("\n a = %d b = %d c = %d", a, b, c);

 printf("\n\n press klavishy... ");
 getch( );

 return 0;
}

 

Паскаль (Откомпилирован и проверен был в Pascal ABC)

program z1;
uses crt;
var a, b , c: integer;

begin

write('Vvedite 3 chisla:  ');
readln(a, b, c);

if (a > b) and (a > c) then writeln(' a = ', a);
if (b > c) and (b > a) then writeln(' b = ', b);
if (c > a) and (c > b) then writeln(' c = ', c);
if (a = b) and (a > c) then writeln(' a = ', a, ' b = ', b);
if (a = c) and (a > b) then writeln(' a = ', a, ' c = ', c);
if (b = c) and (b > c) then writeln(' b = ', c, ' c = ', c);
if (a = b) and (a = c) then writeln(' a = ', a, ' b = ', b, ' c = ', c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота