В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Cekretcv
Cekretcv
25.11.2021 01:14 •  Информатика

С. напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. если отрицательных элементов нет, то сообщить об этом) p.s. в паскале

Показать ответ
Ответ:
STALKER18KEK
STALKER18KEK
15.07.2020 17:11
Var
  n, i, s, k:integer;
  a:array [1..30] of integer;
begin
  writeln('Vvedite massiv');
  for i:=1 to 30 do
  readln(a[i]);
  writeln('Massiv');
  for i:=1 to 30 do
  write(a[i],' ');
  writeln();
  k:=0; s:=0;
  for i:=1 to 30 do
  if a[i]<0 then
  begin
  s:=a[i]+s;
  k:=1;
  end;
  if k=1 then
  writeln('Summa otricatelnih elementov: ',s)
  else
  writeln('Otricatelnih elementov net');
  readln();   
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота