Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Jnash99
02.01.2023 11:29 •
Информатика
С++ напишите программу, которая в четырехзначном числе меняет местами цифры сотен и десятков. вывести полученное число. ввод вывод 1267 1627
Показать ответ
Ответ:
nikita8989
08.10.2020 18:56
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include <iostream>
using namespace std;
int main()
{
int number;
cin >> number;
number = 1000 * (number / 1000) + 100 * (number / 10 % 10) + 10 *
(number / 100 % 10) + number % 10;
cout << number;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Jfigh
07.02.2022 09:07
Цепочка из трёх бусин, помечены латинскими буквами формируется по следующему правилу: -на втором месте цепочки стоит одна из бусин B,А,Е -в начале одна из бусин E,C,D,...
SuperLexa555
08.05.2020 15:08
Дан целочисленный массив из 30 элементов. элементы могут принимать значения от 160 до 200 ¬– рост учащихся выпускного класса. в баскетбольную команду берут тех, чей рост...
паулодибала
18.04.2022 14:20
Задание 1. В Excel составить таблицу, в первой колонке которой ФИО кандидатов на должность в спец. отдел организации, в остальных 8-10 – характеристики кандидатов (пол,...
Ломастер254630
21.05.2021 02:34
Корпоративные информационные системы – это 1. информационная система, осуществляющая бизнес в Интернете 2. информационная система, предоставляющая услуги по доступу в...
paatalizip08mh2
31.12.2021 09:40
Какие ошибки допущены в следующей программе: A = 3.5 B = 4 S = A*B*D...
Нифи2005
05.04.2023 12:21
Электронное устройство , работающее с инфориацией....
lyubimov2006
21.05.2022 19:51
Запишите содержимое (в шестнадцатеричной системе) регистра DL, полученное в результате выполнения следующих операторов ассемблера: MOV DL, 0F1h MOV CL, 3 SHR DL, CL...
Victoria119900
23.03.2022 06:04
Урівнобічній трапеції один кут більший за іншого на 50° знайти кути трапеції іть скоріше...
taniabelkova
23.03.2022 06:04
Краткому ионному уравнению hso3 +oh=so3 +h2o отвечает взаимодействие электролитов : 1)khso3 и koh 2)ca(hso3)2 и h2so4 3)nahso3 и hcl 4) ba(hso3)2 и ba(oh)2...
merimargaryan
15.11.2021 16:01
Основи трапеції відносяться як 3 : 5 а різниця їх довжин дорівнює 4 см знайти середню лінію трапеції іть скоріще...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
using namespace std;
int main()
{
int number;
cin >> number;
number = 1000 * (number / 1000) + 100 * (number / 10 % 10) + 10 *
(number / 100 % 10) + number % 10;
cout << number;
}