В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
РусикЛох
РусикЛох
11.02.2021 08:03 •  Информатика

С

Напишем программу, которая имитирует процесс ввода пароля:
если пароль введен верно, должны выводиться сообщение "Successful login", если же пароль был введен неправильно, то должно выводиться сообщение "Wrong password". Если же пароль был введен неправильно 3 раза, то процесс ввода должен прерываться и должно выводиться сообщение "Access denied".

Начинаться программа должна с вывода сообщения "Enter correct password", после чего должно предлагаться ввести правильный пароль, после чего уже должны вводиться попытки ввода этого пароля.

Формат входных данных

Исходная строка p - правильный пароль.

Неопределенное количество строк возможных паролей.

Формат выходных данных

Сообщения в виде, описанном в условии.

входные данные

qwerty123

Qwerty12

QwErTy123

qwerty123

QWERTY

qwertty

QwERtyY

1234

выходные данные

Enter correct password

Wrong password

Wrong password

Successful login

Enter correct password

Wrong password

Wrong password

Wrong password

Access denied

Показать ответ
Ответ:
сюрприз23456789
сюрприз23456789
18.02.2021 18:27

Объяснение:

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string p = "qwerty123", p2;

  int k=0;

  cout << "Enter correct password"<<endl;

  while(p2!=p || k<3){

      cin >> p2;

      if(p == p2) { cout << "Successful login" << endl; k=4;}

      if(p != p2) {

         cout <<"Wrong password" << endl;

         k++;}

      if(k==3) { cout <<"Access denied" << endl;}

  }

   

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота