В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
epoluektova
epoluektova
12.08.2021 02:09 •  Информатика

С++

написать программу с подробными комментариями , которая

1. обьявляет переменную cord типа int , значение которой вводит пользователь

2. делает проверку ввода : если вводится символ или несколько символов (кроме ' . '), программа очищает поток ,выводит в консоль сообщение об ошибке и кидает на этап ввода переменной cord. если вводят ' . ' ,то программа выводит сообщение о том , что введена точка, если введено число, то программа просто заканчивается

Показать ответ
Ответ:
kirilsex69
kirilsex69
21.10.2021 00:58

В зависимости от контекста, области видимости и языка (некоторые языки не учитывают регистр символа (строчная/заглавная буква), некоторые учитывают), переменные sum и Sum могут являться как одной и той же переменной, так и разными переменными. А в некоторых языках, например, в Python, sum([iterable]) - встроенная функция, выполняющая сложение всех элементов переданной ей последовательности. Вопрос некорректен. ответ можно дать относительно двух языков, нынче популярных в школах:

PascalABC.NET: Переменные sum и Sum по факту являются одной и той же переменной.

Python: sum и Sum являются двумя разными именами, одно из которых может быть переменной, а второе - имя встроенной функции стандартной библиотеки.

Постарайтесь впредь задавать более конкретные вопросы, которые трудно интерпретировать "не так, как нас учили"

0,0(0 оценок)
Ответ:
Martina17
Martina17
27.01.2022 15:01
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
function FS(a,b:real):=0.5*a*b;
begin
  var a,b:real;
  Write('Катеты первого треугольника: '); Read(a,b);
  var S1:=FS(a,b);
  Write('Катеты второго треугольника: '); Read(a,b);
  var S2:=FS(a,b);
  if S1>S2 then Writeln('Площадь первого треугольника больше')
  else
    if S1<S2 then Writeln('Площадь второго треугольника больше')
  else Writeln('Площади треугольников равны')
end.

Тестовое решение
Катеты первого треугольника: 4.18 6
Катеты второго треугольника: 5.4 3.9
Площадь первого треугольника больше
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота