В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Лиопольд
Лиопольд
17.04.2021 14:05 •  Информатика

С. написать программу для : пользователь вводит с клавиатуры величину, выраженную в килобайтах. программа переводит ее в биты и мегабайты. в паскале

Показать ответ
Ответ:
zhaniyaadilshi
zhaniyaadilshi
26.05.2020 07:36

var x: real;

begin

writeln('Введите число(Кб): ');

readln(x);

writeln(x,' Кб = ',x*1024*8,' бит');

writeln(x,' Кб = ',x*1024,' байт');

writeln(x,' Кб = ',x/1024,' Мб');

end.

0,0(0 оценок)
Ответ:
AlinaVaisberg
AlinaVaisberg
26.05.2020 07:36

program line_4;

uses crt;

var

kb, b: longint;

mb: real;

begin

clrscr;

write(‘kb (килобайт) = ‘); readln(kb);

b:=kb*1024*8;

mb:=kb/1024;

writeln(kb,‘ килобайт = ‘, b, ‘ бит = ‘, mb:6:4, ‘ мб’);

readkey;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота