В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
matvik1992
matvik1992
22.10.2020 04:15 •  Информатика

С клавиатуры вводится трёхзначное число. Составьте программу, выводящую на экран слово «Да», если его первая цифра чётная, и слово «Нет» в остальных случаях.

Показать ответ
Ответ:
yuliam2015
yuliam2015
07.05.2020 21:30

program zz1;

var n,n1,n2,n3:integer; //задаем переменные

begin

write('введите заданное трехзначное число');

read(n); //вводим с клавиатуры заданное трехзначное число

n1:=n div 100; //находим первую цифру числа

n2:=(n mod 100) div 10; //находим вторую цифру числа

n3:=n mod 10; //находим третью цифру числа

if (n1 mod 2 = 0)and(n2 mod 2 = 0)and(n3 mod 2 = 0) //проверяем, если все цифры четные, то выводим один ответ, если нет, то другой

then write('все цифры числа четные ') else write('некоторые цифры числа не четные');

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота