В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MaxHelpMelol
MaxHelpMelol
08.05.2023 07:02 •  Информатика

с информатикой (8 класс программирование в PaskalABC)
1.Строчные английские буквы расположены в кодовой таблице символов в порядке своего следования в алфавите и имеют коды с 97 по 122. Написать программу, которая принимает на ввод одну из строчных букв английского алфавита, а возвращает её порядковый номер в алфавите и букву с тем же порядковым номером, но с конца.
Пример: Порядковый номер буквы d в английском алфавите – 4, буква с тем же порядковым номером, но с конца – w.
2.Написать программу, которая проверяет истинность высказывания о том, что введённое пользователем число х – целое.
Пример: при x = 7.74, значение истинности высказывания – false.
3.Написать программу, которая проверяет истинность высказывания о том, что слово из пяти букв, введённое пользователем, является палиндромом.
Палиндром – это слово которое читается одинаково как слева направо, так и наоборот.
Пример: при слове довод, значение истинности высказывания – true.
4.Найти наибольшее из двух чисел, введённых пользователем. Если числа равны между собой, вывести любое из них.
Пример: из чисел 75.2 и 65.1 наибольшее – 75.2.
5.3 отрезка заданы своими длинами. Определить, образуют ли эти отрезки треугольник, и если образуют, то какой: остроугольный, прямоугольный или тупоугольный.
(тут должны быть 3 треугольника)

Пример: отрезки с длинами равными 45, 11 и 60 не образуют треугольник.

Показать ответ
Ответ:
kalishevij99
kalishevij99
09.01.2023 09:27
{ Free Pascal - fpc 2.6.4 }
var
  i,n:integer;
  A,B:array of integer;
  p:longint;
begin
  Write('Число элементов в векторах='); Read(n);
  Randomize;
  SetLength(A,n);
  Writeln('Вектор A');
  for i:=0 to n-1 do begin A[i]:=Random(51)-25; Write(A[i],' ') end;
  Writeln;
  SetLength(B,n);
  p:=0;
  Writeln('Вектор B');
  for i:=0 to n-1 do begin
    B[i]:=Random(51)-25;
    Write(B[i],' ');
    p:=p+A[i]*B[i]
    end;
  Writeln;
  Writeln('Скалярное произведение равно ',p);
end.

Тестовое решение:
Число элементов в векторах=15
Вектор A
-16 -6 -1 6 -6 7 22 4 16 19 3 -21 19 22 7
Вектор B
21 21 -2 -8 -3 25 -4 20 6 -11 8 10 -16 -16 19
Скалярное произведение равно -1145
0,0(0 оценок)
Ответ:
Вано111111111111
Вано111111111111
23.02.2021 21:32

Перед включением утюга необходимо проверить исправность проводки и корпуса.

Под ногами утюжильщицы должен быть резиновый коврик.

При легком покалывании рук во время работы следует отключить утюг и вызвать наладчика – покалывание происходит при замыкании на корпус.

Во время работы необходимо следить , чтобы шнур не касался подошвы утюга во избежание порчи изоляции.

Необходимо следить за нагревом утюга в соответствии с указателем терморегулятора.

В случае перегрева утюга нужно выключить его и охлаждать, проводя по влажной ткани.

Необходимо выключать утюг во время перерыва и по окончании работы.

При обнаружении неисправности утюга, розетки, вилки или шнура прекратить работу и вызвать электромонтера.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота