С++ Дан массив из 10 элементов. Вывести на экран девятый элемент. Точность чисел - 2 знака после запятой.
Формат входных данных
Вводятся 10 вещественных числел ai, не превосходящих 1000 по абсолютной величине и имеющих не более двух знаков после запятой, — элементы массива.
Формат выходных данных
Вывести на экран девятый элемент.
входные данные
1.01 2.02 3.03 4.04 5.05 6.06 7.07 8.08 9.09 10.10
выходные данные
9.09
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт =
20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт
program raf105;
var i,min,kolN,sumN,sariN:integer;
a:array[1..30] of integer;
begin
writeln('Элементы массива:');
min:=99;
for i:=1 to 30 do
begin
a[i]:= random(1,60);
write(a[i],' ');
if (a[i]<min) and ((a[i] mod 4)=0)
then min:= a[i];
if ((a[i] mod 2)<>0)
then
begin
kolN:= kolN+1;
sumN:= sumN+a[i];
end;
end;
writeln;
if min=99
then min:=0;
sariN:= round(sumN/kolN);
writeln('Минимальное значение среди чётных элементов кратных четырём:');
writeln(min);
writeln('Среднее арифметическое среди нечётных элементов:');
writeln(sariN);
end.
Язык программирования PascalABC