В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruslan428
ruslan428
15.12.2021 09:44 •  Информатика

Рома и денис отправились на соревнование по программированию. в долгой дороге вспоминали операции над строками. денис сказал, что в python строки можно умножать на чис- ло, тогда рома, программирующий на с++, решил придумать операцию перемножения строк. по версии ромы, умножение строки s длины n на
строку t обозначается как s · t и равно строке t + s1 + t + s2 + . . + t + sn + t, где si обозначает i-й символ строки s, а знаком «+» обозначе- но сложение (конкатенация) строк. например, произведением строк «abc» и «de» является строка «deadebdecde», а произведением строк «z» и «ab» является
строка «abzab». обратите внимание, что, в отличие от умножения чисел, произведение строк s и t, вообще говоря, не равно произведению строк t и s. денис решил продолжить мысль ромы — он, как ценитель прекрасного, решил определить кра- соту строки как максимальную длину подряд идущей группы одинаковых
букв. например, красота строки «xayyaaabca» равна 3, так как самая длинная группа подряд идущих одинаковых букв — это «aaa», а красота строки «qwerqwer» равна 1, потому что все соседние буквы в ней различны. чтобы развлечь дениса, рома написал ему на листочке n строк p1, p2, p3, . . , pn и попросил
его вычислить красоту строки (. ·p2)·p3)·. .)·pn. денис не до конца понял, как работает умножение ромы, но не хочет признаваться в этом, поэтому просит посчитать красоту этой строки вас. рома знает, что денис слишком впечатлительный, поэтому гарантирует, что красота полученной строки не
превосходит 109 . формат входных данных в первой строке содержится число n (1 ⩽ n ⩽ 100 000) — количество строк, которые написал рома. в следующих n строках содержатся непустые строки p1, p2, . . , pn, состоящие из маленьких букв алфавита. гарантируется, что суммарная длина строк не превосходит
100 000, а также, что красота произ- ведения всех строк не превосходит 109 . формат выходных данных выведите одно целое число — красоту произведения строк. примеры стандартный ввод стандартный вывод 3 a b a 3 2 bnn a 1

Показать ответ
Ответ:
Tamalova5
Tamalova5
09.09.2020 05:34

#include <iostream>

#include <stdio.h>

#include <stdlib.h>

#include <math.h>

int main() {

int a, b, c, y = 3;

scanf("%d", &a);

a = pow(a, 2);

scanf("%d", &b);

b = pow(b, 2);

scanf("%d", &c);

c = pow(c, 2);

while(y > 2){

 if (a == b + c ){

 y = 1; break;

}

 if (b == c + a ){

 y = 1;  break;

}

 if (c == a + b) {

 y = 1; break;

}

 if (a != b + c ){

 y = 2; break;

}

 if (b != c + a ){

 y = 2; break;

}

 if (c != a + b ){

 y = 2; break;

 

}

}

printf("\nPryamougolniy : ", y);

switch (y) {

 case 1: printf("Yes"); break;

 case 2: printf("No"); break;

}

return 0;

}

Объяснение:

Dev C++

0,0(0 оценок)
Ответ:
alinaburlaka
alinaburlaka
18.12.2022 19:10

Объяснение:

Наливаете 5-литровую емкость полностью, переливаете в 7 литровую. Опять наливаете 5-литровую и доливаете из нее 7-литровую полностью. Теперь у вас в 5-литровой 3 литра. Выливаете 7-литровую и переливаете в нее 3 литра из 5-литровой. Наливаете 5-литровую полностью и доливаете из нее до полной 7-литровую. Теперь у вас в 5-литровой остался один литр. Выливаете 7-литровую, переливаете 1 литр из 5-литровой в 7-литровую, наливаете полную 5-литровую и переливаете в 7-литровую. Теперь у вас там 6 литров.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота