В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Aleksandra66611
Aleksandra66611
01.04.2022 12:00 •  Информатика

Решите с pascal 1. Найти сумму чисел, которые оканчиваются на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа.
2. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа.
3. Пользователь вводит два целых числа A и B (А 4. Даны натуральные числа от 101 до 321. Напечатать те из них, которые делятся БЕЗ ОСТАТКА на 4, но не делятся на 6.

Показать ответ
Ответ:
adele978645312
adele978645312
14.06.2021 18:17

1)

var

n,x,s,i : integer;

begin

s:=0;

write('Введите n: '); read(n);

for i:=1 to n do

begin

write('X - ', i, ' = '); read(x);

if x mod 10 = 9 then

s:=s+n;

end;

writeln('Сумма с 9 на конце = ', s);

end.

2)

var

n,i,max,x : integer;

begin

max:=0;

write('Введите n: '); read(n);

for i:=1 to n do

begin

if (x > max) and (x mod 5 = 0) then

max:=x;

write('X - ',i,' = '); read(x);

end;

writeln('Максимальное, кратное 5 = ', max);

end.

3)

var

a,b,i : integer;

begin

write('a = '); read(a);

write('b = '); read(b);

for i:=a to b do

begin

if (i mod 4 = 0) and (i mod 6 <> 0) then

writeln(i);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота