Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
АпаснаяЯ
21.12.2022 22:16 •
Информатика
Решите по информатике в програме "pascalabc.net" найти 10 значений выражения 1/х для случайных х из интервала от -10 до 20
Показать ответ
Ответ:
Sania24sania
06.10.2020 09:35
1. Короткий вариант
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
SeqRandom(10,-10,20).Select(x->(x,1/x)).Println(NewLine)
end.
Пример
(13,0.0769230769230769)
(-10,-0.1)
(9,0.111111111111111)
(-5,-0.2)
(14,0.0714285714285714)
(18,0.0555555555555556)
(15,0.0666666666666667)
(3,0.333333333333333)
(-5,-0.2)
(-9,-0.111111111111111)
2. "Красивый" вариант
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
SeqRandom(10,-10,20).Select(x->(x,1/x))
.Foreach(x->Writeln(x[0]:3,x[1]:15:8))
end.
Пример
18 0.05555556
-10 -0.10000000
16 0.06250000
6 0.16666667
15 0.06666667
13 0.07692308
5 0.20000000
18 0.05555556
-1 -1.00000000
13 0.07692308
3. А так писали наши деды четверть века назад...
var
i,x:integer;
begin
Randomize;
for i:=1 to 10 do begin
x:=Random(31)-10;
Writeln(x:3,1/x:15:8)
end
end.
Пример
-7 -0.14285714
11 0.09090909
-2 -0.50000000
-10 -0.10000000
14 0.07142857
-7 -0.14285714
-5 -0.20000000
5 0.20000000
13 0.07692308
10 0.10000000
0,0
(0 оценок)
Популярные вопросы: Информатика
TINAdTINA
14.02.2023 11:05
Написать программу, которая просит пользователя ввести 3 целых числа, а затем выводит сумму, разность и частное этих чисел. Частное - вещественное число. Напишите в паскале...
хеллокиттичка
25.11.2022 05:35
это про Paint 5. Как нарисовать круг, если вы знаете его центр и радиус? 6. Почему нарисованную фигуру сложно переместить после освобождения кнопки мыши?...
Salina1904
09.02.2022 05:10
PYTHON писать через логическую функцию: Напишите логическую функцию, которая определяет, являются ли два переданные ей числа взаимно то есть, не имеющими общих делителей,...
pomosh221314
20.11.2021 06:59
с задачей на округление вверх (Паскаль) 1. Ваш любимый дядя – директор фирмы, которая делает евроремонты в офисах. В связи с финансово-экономическим кризисом, дядюшка решил...
SeverinaWinter
24.12.2022 16:08
Представление данных в электронных таблицах в виде диаграмм и графиков....
fooorl
07.07.2020 07:55
В таблице приведены за к поисковому серверу. Для каждого за указан его код — соответствующая буква от А до Г. Запиши коды за слева направо в порядке возрастания количества...
vasilyeva08079oz7ptx
15.05.2020 20:58
очень Надо в программе кумир с исполнителем Чертежник нарисовать конфету. Не используя сместиться в точку только сместиться на вектор...
дитанатор
29.06.2020 02:46
Исправь ошибки в коде страницы, так чтобы, заголовок окна – Звук и видео, фон страницы был серебристого цвета, текст имел полужирное курсивное начертание, цвет текста –...
Do6pblu322
11.09.2020 22:23
кто сможет, ответы не верные...
спаркер
12.11.2022 10:32
Переведите А13 из шестнадцатиричной системы счисления в шестнадцатиричную систему счисления...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
SeqRandom(10,-10,20).Select(x->(x,1/x)).Println(NewLine)
end.
Пример
(13,0.0769230769230769)
(-10,-0.1)
(9,0.111111111111111)
(-5,-0.2)
(14,0.0714285714285714)
(18,0.0555555555555556)
(15,0.0666666666666667)
(3,0.333333333333333)
(-5,-0.2)
(-9,-0.111111111111111)
2. "Красивый" вариант
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
SeqRandom(10,-10,20).Select(x->(x,1/x))
.Foreach(x->Writeln(x[0]:3,x[1]:15:8))
end.
Пример
18 0.05555556
-10 -0.10000000
16 0.06250000
6 0.16666667
15 0.06666667
13 0.07692308
5 0.20000000
18 0.05555556
-1 -1.00000000
13 0.07692308
3. А так писали наши деды четверть века назад...
var
i,x:integer;
begin
Randomize;
for i:=1 to 10 do begin
x:=Random(31)-10;
Writeln(x:3,1/x:15:8)
end
end.
Пример
-7 -0.14285714
11 0.09090909
-2 -0.50000000
-10 -0.10000000
14 0.07142857
-7 -0.14285714
-5 -0.20000000
5 0.20000000
13 0.07692308
10 0.10000000