В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Решите на питоне:Остап Бендер, сын турецко-подданного, за свою жизнь переменил много занятий. Живость характера постоянно кидала его в разные концы страны и теперь привела в Старгород без носков, без ключа, без квартиры и без денег. Лежа в теплой до вонючести дворницкой, Остап Бендер отшлифовывал в мыслях возможные варианты своей карьеры.

Напишите программу, которая ему в этом, а именно из предложенных чисел выберет только те, что больше последнего среди всех введенных чисел и имеют с ним ту же чётность.

Формат ввода
Вводится строка целых чисел, записанных через пробел.

Формат вывода
Вывести числа, которые больше последнего и имеют с ним ту же чётность, без повторений, порядок вывода значения не имеет.

Показать ответ
Ответ:
Dilnaz10011
Dilnaz10011
12.08.2022 04:07

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Ответ:
katruhanchik
katruhanchik
11.05.2020 00:59
Информационный вес символа при алфавитном подходе считается, что каждый символ текста имеет определенный информационный вес, информа­ционный вес символа зависит от мощности алфавита. а ка­ким может быть наименьшее число символов в алфавите? оно равно двум! скоро вы узнаете, что такой алфавит ис­пользуется в компьютере. он содержит всего 2 символа, ко­торые обозначаются цифрами «0» и «1». его называют дво­ичным алфавитом. изучая устройство и работу компьютера, вы узнаете, как с всего двух символов можно пред­ставить любую информацию. информационный вес символа двоичного алфавита принят за единицу информации и называется 1 бит.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота