Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
rozik080
10.08.2022 03:17 •
Информатика
Решите кумир практикум 6с
Показать ответ
Ответ:
Ram543
13.12.2020 06:29
While (tnum != 0) //tnum, tden - числитель и знаменатель искомой дроби
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
0,0
(0 оценок)
Ответ:
evgenijpetrov
08.03.2023 07:22
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
maksim22771
02.06.2021 14:25
Решить на Паскале. 25б Не используйте ответы в интернете...
SvetaCat115
20.11.2022 02:56
Маша составляет 6-буквенные слова из букв З, Е, Р, К, А, Л, О, содержащие букву К, но не более 4 раз...
ГогольВася11
07.04.2022 17:41
Язык программирования python 8 класс...
ашме
14.12.2022 08:22
Поле GF (24) порождается примитивным многочленом p (x) = x4 + x + 1. Построить таблицу степеней примитивного элемента α. Для кодирования использован двоичный код БЧХ...
Боббоянн
22.12.2022 10:51
[09:55, 12.05.2021] Информатик : Работа №1 1. В электронной таблице значение формулы =СУММ(С3:Е3) равно 21. Чему равно значение формулы =СРЗНАЧ(С3:F3), если значение...
QbQbQb
12.08.2020 05:43
Команди как нарисовать Букви А и Т в пайтоне ...
Otlichnisa140455
28.06.2022 01:53
Рисунок дельфина по координатам в питон...
qweravq
19.09.2021 04:28
Ишю тиму в фре фаер (игра)3 человека написать на вацап 87767351490...
molkes
13.12.2020 08:30
Проверьте,делится ли сумма произвольных трех чисел,введенных с клавиатуры,на последнее из них без остатка. в ( quick basic ) решить...
Ksyxa03
03.02.2022 18:21
Садовник посадил на клумбе прямоугольной формы 10 кустов роз . расстояние между кустами 1 м 20 см. поливая цветы, садовник обошел клумбу по периметру. сколько метров...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
{
if (tnum < tden)
{
temp = tnum;
tnum = tden;
tden = temp;
}
tnum = tnum - tden;
}
gcd = tden; //вычисляем наибольший общий делитель
numerator = numerator / gcd; //делим числитель и знаменатель на
НОД, получаем сокращенную дробь
denominator = denominator / gcd;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
then writeln('Не квадратное уравнение!')
else begin
d:= sqr(b)-4*a*c;
if d < 0 then writeln('Нет корней')
else begin
x1:= (-b+sqrt(d))/2*a;
x2:= (-b-sqrt(d))/2*a;
writeln ('X1 =',x1,' X2 =',x2);
end;
end;
end.