В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
hahahahahaha2
hahahahahaha2
31.12.2022 23:20 •  Информатика

Решите:
Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трёхзначного числа х. Значение х ввести с клавиатуры.
Язык программирования Паскаль

Показать ответ
Ответ:
Лина1990
Лина1990
01.02.2021 01:00

Прости что не текстом :(


Решите: Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трё
0,0(0 оценок)
Ответ:
ivanpowerflusi
ivanpowerflusi
01.02.2021 01:00

var

s,pr,x : integer;

begin

readln(x);

x := abs(x);

s:= 0;

pr:= 1;

while x > 0 do

begin

s := s + x mod 10;

pr := pr * x mod 10;

x:= x div 10;

end;

writeln('S = ',s);

writeln('PR = ',pr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота