В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nvel1999
nvel1999
28.11.2021 16:52 •  Информатика

Решить задачу. Написать программу, которая формирует случайным образом и выводит на экран массив из N целых чисел, лежащих в диапазоне от -5 до 5. Вывести на экран только отрицательные элементы этого массива в обратном порядке и вычислите их сумму.​

Показать ответ
Ответ:
NadiaU0
NadiaU0
29.09.2020 11:16

Унарная система счисления – система счисления с основанием 1. Используется, например, при подсчёте небольшого количества предметов: когда подсчитывается очередной предмет ставится единица (или зарубка, черточка, точка или любая другая отметка, также можно откладывать камешки, например). Количество таких единиц совпадает с количеством предметов.


Позиционная система счисления – система счисления, в которой значение цифры зависит от места, на котором она стоит. Например, в десятичной системе стоимость цифры возрастает в 10 раз, если она сдвигается на одну позицию влево: 1 в записи числа 321 означает просто один, а в числе 213 – уже 10.


Непозиционная система счисления – система счисления, в которой значение цифры не зависит от того места, на котором она стоит. Обычно примером непозиционной системы счисления называют римские числа, хотя это не совсем верно: если цифра с меньшим номиналом стоит перед цифрой с большим номиналом, то её значение вычитается из большей цифры, например, XI = 11, но IX = 10 - 1 = 9. Другие примеры – древнеегипетские числа, числа племён майя.

0,0(0 оценок)
Ответ:
FireGame228
FireGame228
25.01.2022 06:35

ответ:ОБЪЯВЛЕНИЕ МАССИВА

Массивы в Паскале используются двух типов: одномерные и двумерные.

Определение одномерного массива в Паскале звучит так: одномерный массив — это определенное количество элементов, относящихся к одному и тому же типу данных, которые имеют одно имя, и каждый элемент имеет свой индекс — порядковый номер.

Описание массива в Паскале (объявление) и обращение к его элементам происходит следующим образом:

Описание массива в Паскале

Объявление массива

var dlina: array [1..3] of integer;

begin

dlina[1]:=500;  

dlina[2]:=400;  

dlina[3]:=150;

...

dlina — идентификатор (имя) массива;

для объявления используется служебное слово Array (в переводе с англ. «массив» или «набор»);

[1..3] — в квадратных скобках ставится номер (индекс) первого элемента, затем две точки и индекс последнего элемента массива, т.е. по сути, указывается количество элементов; количество элементов массива называется размерностью массива

of integer (с англ. «из целых чисел») — указывает, к какому типу относится массив, of здесь — служебное слово.

 

Объявить размер можно через константу:

размер массива через константу

ИНИЦИАЛИЗАЦИЯ МАССИВА

Кроме того, массив может быть сам константным, т.е. все его элементы в программе заранее определены. Описание такого массива выглядит следующим образом:

const a:array[1..4] of integer = (1, 3, 2, 5);

Заполнение последовательными числами:

заполнение массива

Результат:

A[1] = 8, A[2] = 9, A[3] = 10, ..., A[N] = A[N-1] + 1

Ввод с клавиатуры:

Пример: Рассмотрим, как происходит ввод массива в Паскале:

writeln ('введите кол-во элементов: ');

readln(n); {если кол-во заранее не известно, - запрашиваем его}

for i := 1 to n do begin

  write('a[', i, ']=');

  read(a[i]);

  ...

end;

...

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота