В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kuzal
kuzal
06.11.2021 05:20 •  Информатика

решить задачу на Питоне, Рекурсия Задача
Напишите программу, содержащую рекурсивную функцию, которая по натуральному числу n, выводит все числа от n до 1. Основная программа должна содержать ввод исходных данных (число n) и вызов функции

Примеры
№ Входные данные Выходные данные
1 6 6 5 4 3 2 1
Запрещенные операторы: for;while;until

Показать ответ
Ответ:
karamendes1p06wtk
karamendes1p06wtk
29.11.2020 01:08

def allnumbers(n):

   if n == 0:

       return 1

   print(n, end=' ')

   allnumbers(n - 1)

n = int(input("Введите число n: "))

allnumbers(n)

Объяснение:

def allnumbers(n):  // Функция allnumbers, которая принимает аргумент n

   if n == 0:  // Если значение переменной n = 0

       return 1  // Выходим из функции

   print(n, end=' ')  // Выводим значение переменной n

   allnumbers(n - 1)  // Рекурсия

n = int(input("Введите число n: "))  // Вводим число n с клавиатуры

allnumbers(n) // Функция

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота