решить задачу через паскаль .
№1 Гражданин 1 марта открыл счет в банке, вложив 1000 р . Через месяц размер вклада увеличелся на 2 % от имеющейся суммы . Определите за какой месяц велечина ежемесячного увелечения вклад превысит 30 р.
№2 Длинна прямоугольного участка земли равна x метров ,а ширина Y метров .Напишите программу вычисления количества досок для забора на заданном участке , если ширина доски 10 сантиметров .
Еще пример: магазинные чеки. Не будет же машина (из-за технической сложности) или человек (из-за лени) писать на чеке: "продано столько-то столько-то того-то того-то ... пакет апельсинов весил шестьсот пядесят три грамма ... итд". На чеке будет табличка, где четко и точно будет написано то, что человек приобрел.
Вот. Так что табличные модели, несомненно, лучше словесных.
#include <iostream>#include <ctime>int main(){ using namespace std; const int ArSize = 10; int ar[ArSize]; int s_less = 0, s_more = 0; int k_less = 0, k_more = 0; srand(time(0)); for (int i = 0; i < ArSize; i++) ar[i] = rand() % 101; for (int i = 0; i < ArSize; i++) cout << ar[i] << ' ';
for (int i = 0; i < ArSize; i++) { if (ar[i] < 50) { s_less = s_less + ar[i]; k_less = k_less + 1; } if (ar[i] > 50) { s_more = s_more + ar[i]; k_more = k_more + 1; } } cout << "\nAverage of numbers less than 50: " << (double)s_less / k_less << endl; cout << "Average of numbers more than 50: " << (double)s_more / k_more << endl; return 0;}