В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
сымбат64
сымбат64
05.10.2022 07:11 •  Информатика

решить задачи на PYTHON. Какие сможете. Буду оооченьь признательнааа
1. Вводится последовательность целых чисел. Известно, что последний элемент последовательности равен 5. Найдите количество положительных чисел и минимальное из них. Разработайте программу для чисел в диапазоне [- 10000..10000]
2. Вводится последовательность целых чисел. Известно, что последний элемент последовательности равен 1. Определите, каких среди них больше: положительных или отрицательных.
3. Известны начальный вклад клиента в банк и процент годового дохода. Определите срок (в годах), через который вклад превысит 1 млн рублей и величину этого вклада.
5. Дано число, определите минимальное основание системы счисления, в которой оно может быть записано. (Максимальная система счисления 10)

Показать ответ
Ответ:
Pahamoseuv
Pahamoseuv
26.04.2022 12:12
Var
  x1, x2, x3, y1, y2, y3, L: real;

begin
  Write('Введите через пробел координаты точки А: ');
  Readln(x1, y1);
  Write('Введите через пробел координаты точки B: ');
  Readln(x2, y2);
  Write('Введите через пробел координаты точки C: ');
  Readln(x3, y3);
  L := sqrt(sqr(x2 - x1) + sqr(y2 - y1)) + sqrt(sqr(x3 - x1) + sqr(y3 - y1));
  Write('Сумма длин AB+AC равна ', L:0:3)
end.

Тестовое решение:
Введите через пробел координаты точки А: -3 2
Введите через пробел координаты точки B: 4.3 1.8
Введите через пробел координаты точки C: 0 7
Сумма длин AB+AC равна 13.134
0,0(0 оценок)
Ответ:
lowander3000
lowander3000
05.05.2020 17:35
Var s:string;   
i,sum:integer; // Объявление переменных
begin             // Начинаем программу
writeln('Vvedite chislo'); // Вывод текста
readln(s); // Ввод текста
sum:=0; // Присваиваем переменной sum значение 0 чтобы при вводе текста отличного от 0, программа выводила правильный результат то есть 0.
for i:=1 to length(s) do if s[i]='0' then sum:=sum+1; // Запускаем счетчик с 1 до length(s) что значит эта команда, она считает сколько в тексте символов. И проверяем с 1 символа до length(s) совпадает ли символ со значением 0, если совпадает то прибавляем 1.
writeln(sum); // Вывод суммы
end. // Конец программы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота