Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
victoria128
29.08.2020 17:48 •
Информатика
Решить в паскале с процедурой . даны действительные a, b, c, d. используя функции поиска максимума двух чисел max и минимума двух чисел min, получить: max(a, b)+min(a, b) +min(c,d) ––––—–– . max(a, b, c, d) + min(a,b,c)
Показать ответ
Ответ:
Неко6тян
01.10.2020 12:12
Function min(a, b: real): real;
begin
if ((a = b) or (a < b)) then result := a
else result := b;
end;
function max(a, b: real): real;
begin
if ((a = b) or (a > b)) then result := a
else result := b;
end;
procedure prog(a, b, c, d: real);
begin
writeln(max(a, b)+min(a, b) + min(c,d));
end;
var a, b, c, d: real;
begin
readln(a, b, c, d);
prog(a, b, c, d);
end.
Вот, тут тебе и процедура, и функции:)
0,0
(0 оценок)
Популярные вопросы: Информатика
uchenica7
11.02.2021 17:09
1. надпись на клавише , находящейся рядом с клавишей pause? 2.надпись на клавише , фиксирующий числовой режим работы дополнительной кклавиатуры? !...
amiranur1
11.02.2021 17:09
Прикладные программы для выполнения на компьютере конкретных - слово из 10 букв?...
marianachornii
02.05.2022 19:47
Уважаемые знатоки ms access, нужна ! пытаюсь связать таблицы номера и проживание клиентов , но выходит данное , подскажите, что делать заранее за ответ!...
TMTEMI
07.05.2020 20:31
Какому логическому выражению соответствует таблица истинности? 1)а& в 2)а или в 3)не(а& в) 4)не а& не в...
erkenova0909
09.07.2021 05:29
Напишите программу которая щапрашивает натуральное число n далее последовательность из n натуральныз чисел и меняет второй элемент и максимальный элемент местами...
KlarissaStet
12.02.2020 20:54
Что нельзя делать без разрешение автора? ( авторское право)...
danikstremers1
26.10.2022 20:23
Что нельзя делать без разрешения автора? ...
eminhesenov20
29.12.2022 23:42
Запиши программы для выполнения проверяемых (на небольшом поле)...
butterflygirl1
16.09.2021 17:40
Заполните ячейки трассировочные таблицы и определите, что выводит данный код: ...
sunnyAkhhhh
17.02.2020 07:15
Напишите код программы которая проверяет введённое число на совершенность примечание число называется совершенным если оно равно сумме всех его делителей меньше его самого. натуральное...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
if ((a = b) or (a < b)) then result := a
else result := b;
end;
function max(a, b: real): real;
begin
if ((a = b) or (a > b)) then result := a
else result := b;
end;
procedure prog(a, b, c, d: real);
begin
writeln(max(a, b)+min(a, b) + min(c,d));
end;
var a, b, c, d: real;
begin
readln(a, b, c, d);
prog(a, b, c, d);
end.
Вот, тут тебе и процедура, и функции:)