Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Yana7112
28.07.2021 07:19 •
Информатика
Решить в паскале перевести заданное количество байтов в биты, килобайты, мегабайты.
Показать ответ
Ответ:
Horosh2545
01.10.2020 13:52
Program Calculator;
var b, kb, mb, bt: real;
begin
write('Введите количество байтов: ');
readln(b); {bytes}
kb:=b/(1 shl 10); {kbytes}
mb:=b/(1 shl 20); {mbytes}
bt:=b*8; {bits}
writeln(bt:1:2, ' - битов ',kb:1:2, ' - килобайтов ',mb:1:2, '- мегабайтов ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
SoniaSS09
21.05.2023 12:59
Укажите наименьшее пятизначное число x, при вводе которого алгоритм печатает 26391. паскаль: var x, y, a, b: integer; begin readln(x); a: =0; b: =0; y: =1; while x 0 do begin...
kononenkoalinka
21.05.2023 12:59
Пробный экзамен по информатики и икт, проверить. для какого из указанных значений числа х ложно выражение: (х меньше 2) или не (х меньше 3) 1)1 2)2 3)3 4)4...
alimbekoffniki
19.01.2020 10:14
Свопросами назовите общие признаки группы (рыбы)...
245mkl
06.02.2020 12:08
Выберите правильный вариант.. 1. Er 10Jahre alt. А. ist; B. bin; C. sind; D. seid. 2. Найдите лишнее слово: А. die Tomaten; B. das Kind ; C. die Eier; D. der Fisch. 3. Укажите...
Дима2005Dima
06.12.2022 00:36
Запиши данную дробь в виде дроби со знаменателем 7: 8/28...
ALMUGGG
06.12.2022 00:36
написать, нет времени...
Ардак00000000
25.07.2020 15:53
Информатика ящики 512 овощей: 128пепцев, 256 огурцов, 64 баклажана и 64 редиса. Какое количество информации содержится в сообщении о том, что из ящика случайным образом были...
vitalik6300
25.07.2020 15:53
2. Установіть хронологічну послідовність подій: о ліквідація Полково-сотенного устрою наЛівобережній Україні; • указ про перетворення лівобережних козацьких полків на регулярніПолки...
meeeoooowww
25.07.2020 15:53
сделать задание. Буду очень благодарна! ...
yardeebro
22.04.2021 22:30
Проанализируйте процессы «культурной революции» в СССР И Китае. Выделите общее о особенное....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var b, kb, mb, bt: real;
begin
write('Введите количество байтов: ');
readln(b); {bytes}
kb:=b/(1 shl 10); {kbytes}
mb:=b/(1 shl 20); {mbytes}
bt:=b*8; {bits}
writeln(bt:1:2, ' - битов ',kb:1:2, ' - килобайтов ',mb:1:2, '- мегабайтов ');
end.