В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
OlyaMonokova
OlyaMonokova
10.12.2021 19:34 •  Информатика

Решить по информатике) нужно написать программу на паскале. тема: циклы вот условие) оргкомитет олимпиады решил организовать обзорную экскурсию для участников олимпиады. для этого был заказан двухэтажный автобус (участников олимпиады достаточно много и в обычный они не умещаются) высотой 437 сантиметров. на экскурсионном маршруте встречаются n мостов. жюри и оргкомитет олимпиады обеспокоены тем, что высокий двухэтажный автобус может не проехать под одним из них. им удалось выяснить точную высоту каждого из мостов. автобус может проехать под мостом тогда и только тогда, когда высота моста превосходит высоту автобуса. организаторам узнать, закончится ли экскурсия благополучно, а если нет, то установить, где произойдет авария. входные данные: во входном файле сначала содержится число n (1< =n< =1000). далее идут n натуральных чисел, не превосходящих 10000 - высоты мостов в сантиметрах в том порядке, в котором они встречаются на пути автобуса. выходные данные: в единственную строку выходного файла нужно вывести фразу "no crash", если экскурсия закончится благополучно. если же произойдет авария, то нужно вывести сообщение "crash k", где k - номер моста, где произойдет авария. фразы выводить без кавычек ровно с одним пробелом внутри.

Показать ответ
Ответ:
aleksiandr999
aleksiandr999
07.10.2020 21:31
Var
tmp,n,i:integer;
begin
Readln(n);
for i:= 1 to n do begin
readln(tmp);
if tmp <= 437 then
begin
  Writeln('Crash ', i);
  halt;
end;
end;
Writeln('No Crash');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота