В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
linasysueva01
linasysueva01
14.10.2020 16:50 •  Информатика

Решить: напишите программу для решения следующей . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. необходимо определить максимальную зарегистрированную скорость автомобиля. если скорость хотя бы одного
автомобиля была меньше 30 км/ч, выведите "yes", иначе выведите "no".программа получает на вход число проехавших автомобилей n(1< n< 30), затем указываются их скорости. значение скорости не может быть меньше 1 и больше 300. программа должна сначала вывести максимальную скорость затем yes или
no. ! пример вводных данных474696366примеры входных данных74no​

Показать ответ
Ответ:
asdasdgasf
asdasdgasf
10.10.2020 01:57

n = int(input())

max_speed = 0

check = True

for i in range(0, n):

   a = int(round(float(input(

   if a > max_speed:

       max_speed = a

   if check == True:

       if a < 30:

           check = False

print(max_speed)

if not check:

   print('YES')

else:

   print('NO')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота