В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
2345Pomogite2345
2345Pomogite2345
04.12.2020 19:46 •  Информатика

решить на языке Python Рассматривается множество целых чисел, принадлежащих числовому отрезку [2481; 14832], которые делятся на 5 или 11 и не делятся на 6, 7, 10, 23. Найдите количество таких чисел и максимальное из них. В ответе запишите два целых числа без пробелов и других дополнительных символов: сначала количество, затем максимальное число.

Показать ответ
Ответ:
milasha24
milasha24
20.06.2021 20:13

A = []

x = 0

y = 0

count = 2481

while count <= 14832:

   if count % 5 == 0 and count % 11 == 0 and count % 6 != 0 and count % 10 != 0 and count % 23 != 0:

       x += 1

       A.append(x)

count = 0

while count <= len(A):

   if y < int(A[count]):

       y = int(A[count])

   count += 1

print(x, y)

ну по идее воть))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота