В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ононрро
ононрро
16.04.2023 21:24 •  Информатика

Решить на языке питон Алиса и Боб получили три большие кучки конфет в качестве подарка. Теперь они хотят разделить эти конфеты между собой настолько честно, насколько это возможно. Чтобы сделать это, Алиса забирает одну кучку с конфетами себе, затем Боб забирает одну из других двух кучек себе. Последняя кучка делится между Алисой и Бобом так, как они хотят: например, возможно, что Алиса возьмет всю кучку себе, а Боб не получит из нее ничего. После того как они возьмут все конфеты из кучек, если у Алисы будет больше конфет, чем у Боба, она выкидывает некоторые конфеты таким образом, что количество ее конфет становится равным количеству конфет Боба. Конечно, Боб сделает то же самое, если у него больше конфет. Алиса и Боб хотят иметь как можно больше конфет каждый, и будут планировать процесс разделения конфет соответственно посчитайте максимально возможное количество конфет, которое может оказаться у Алисы после процесса их разделения (конечно же, у Боба будет столько же конфет). Формат ввода Единственная строка запроса содержит три целых числа a , b и c ( 1 ≤ a , b , c ≤ 1 0 в 16 степени ) — количество конфет в первой, второй и третьей кучках соответственно. Формат вывода Выведите ответ - максимальное количество конфет, которое Алиса может иметь после разделения, если и Алиса, и Боб будут действовать оптимально (конечно же, Боб будет иметь такое же количество конфет).

Показать ответ
Ответ:
КсенияА2006
КсенияА2006
09.10.2021 13:22
В данном случае всё зависит от контекста вопроса.

Если "понимает" процессор, то разговор идёт о прямых командах ему. Самый яркий пример - компилируемые ЯП вроде С или Pascal, где исходный код пользователя переводится в прямые команды ядру системы (уменьшение уровня абстракции).

Если за "завершение строки" воспринимать конец команды (в вышеназванных ЯП это ';'), то компилятор в процессе компиляции (тавтология) разделяет эти строки на отдельные команды, каждая из которых имеет свою последовательность процессорных действий.

Никакие CRLF (конец строки в Windows/DOS) и LF (в *nix-системах) вне строковых литералов (символов в кавычках вроде 'hello') для процессора роли не играет абсолютно.

В принципе, об интерпретируемых ЯП можно сказать то же самое. Для процессора "завершения строки" как такового не существует.

простить, если дал не тот ответ, что требовалось.
0,0(0 оценок)
Ответ:
zorlnaviitukp00zmd
zorlnaviitukp00zmd
10.11.2020 21:15
1)
#include <stdio.h>
 
int main() {
 int a = -1;
 while(a != 0)
    scanf("%d", &a);
}
2)
#include <stdio.h>
#include <math.h>
 
int main() {
 int a;
 scanf("%d", &a);
 int prime = 1;
 for(int i = 2; i <= sqrt(a)+1; i++)
    if(a%i == 0) {
      prime = 0;
      break;
    } if((prime == 0 && a != 2) || a == 1) printf("NO\n");
 else printf("YES\n");
}
3)
#include <stdio.h>

int main() {
 int a[5];
 for(int i = 0; i < 5; i++)
   scanf("%d", &a[i]);
 for(int i = 0; i < 5; i++)
   printf("%d ", a[i]);
 printf("\n");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота