Решить на языке Питон 3! Неспокойно сейчас на стапелях шестого дока межгалактического порта планеты Торна. Всего через месяц закончится реконструкция малого броненесущего корвета ’Эния’. И снова этому боевому кораблю и его доблестной команде предстоят тяжелые бои за контроль над плутониевыми рудниками Сибелиуса. Работа не прекращается ни на секунду, лазерные сварочные аппараты работают круглые сутки. От непрерывной работы плавятся шарниры роботов-ремонтников. Но задержаться нельзя ни на секунду. И вот в этой суматохе обнаруживается, что термозащитные панели корвета вновь требуют обработки сульфидом тория. Известно, что на обработку одного квадратного метра панели требуется 1 нанограмм сульфида. Всего необходимо обработать N прямоугольных панелей размером A на B метров. Вам необходимо как можно скорее подсчитать, сколько всего сульфида необходимо на обработку всех панелей ’Энии’. И не забудьте, что панели требуют обработки с обеих сторон. Формат ввода Содержится 3 целых положительных числа N,A,B .N(N≤100), A(A≤100), B(B≤100). Формат вывода Вывести единственное число - вес необходимого для обработки сульфида тория в нанограммах.
var
f,g: text;
n,a,b,s: integer;
begin
assign(f,'input.txt');
reset(f);
read(f,n); read(f,a); read(f,b);
close(f);
assign(g,'output.txt');
rewrite(g);
s:=n*a*b*2;
write(g,s);
close(g);
writeln('Èñêîìûå äàííûå çàïèñàíû â ôàéë "output.txt"');
readln;
end.
0
Объяснение:
Если необходимо проводить проверку на существование файла - она в разных паскалях проводится по разному.
А эта задача решается очень просто - произведение n, a, b умножается еще и на 2.