В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vedruss7881
vedruss7881
27.09.2022 22:05 •  Информатика

Решить на питоне , , в интернете все решения ! 34 . 1) дано натуральное число n. выведите слово yes, если число n является точной степенью двойки, или слово no в противном случае. операцией возведения в степень пользоваться нельзя! 2)дано натуральное число n> 1. выведите его наименьший делитель, отличный от 1. решение оформите в виде функции mindivisor(n). алгоритм должен иметь сложность o(корень из n) . указание. если у числа n нет делителя не превосходящего корень из n , то число n — простое и ответом будет само число n. 3) последовательность фибоначчи это последовательность типа xn = xn – 1 + xn – 2 , n > 2, n - номер числа в последовательности. дано натуральное число a. определите, каким по счету числом фибоначчи оно является, то есть выведите такое число n, что xn=a. если а не является числом фибоначчи, выведите число -1. 4) последовательность состоит из натуральных чисел и завершается числом 0. определите значение второго по величине элемента в этой последовательности, то есть элемента, который будет наибольшим, если из последовательности удалить наибольший элемент. входные данные вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания). выходные данные выведите ответ на .

Показать ответ
Ответ:
Karina2048
Karina2048
04.08.2020 11:26
1.
N=int(input())
s=2
flag=False
for i in range(N):
      if N=s:
           flag=True
           break
      else:
           s*=2
if flag:
    print('Yes')
else:
    print('No')

2.
n=int(input())
def MinDivisor(n):
     nod=-1
     for i in range(n-1):
          if n%i=0:
              return i
              break

if MinDivision(n)==-1:
    print(n,' число является простым.')
else:
    print(MinDivision(n))

3.
A=int(input())
x=x1=1
s=0
while x1<A+2:
   b=x
   x=x1
   x1+=b
   s+=1
if x1==A:
    print(s)
else:
    print(-1)

4. 
a=[]
while 1:
   s=int(input())
   if s==0:
       break
   a.append(s)
a.sort()
print(a[-2])
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота