В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
milena195
milena195
08.08.2021 05:45 •  Информатика

Решить на паскале.
с клавиатуры вводятся координаты точки на плоскости (x, y – действительные числа. написать программу, определяющую принадлежность точки заштрихованной области, включая ее границы.

Показать ответ
Ответ:
TuyaChimitova
TuyaChimitova
10.10.2020 10:08

program Test;

var

 x, y: Double;

begin

 WriteLn ('Введите координаты x и y: ');

 ReadLn (x, y);

 if (x >= 0) and (x <= Pi) and (y >= 0) and (y <= 0.5) and (y <= Sin (x)) then

   WriteLn ('Принадлежит')

 else

   WriteLn ('Не принадлежит');

 ReadLn;

end.

Объяснение:

Первые 4 условия проверяют прямоугольник от (0, 0) до (п, 0,5)

последнее условие проверяет левый и правый край этого прямоугольника на принадлежность к графику Sin (x)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота